WCC upgrade fails due to conflicts with old packages

Document ID : KB000008954
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

WCC upgrade fails with error messages:

File ../autosys/lib/libstart_rem.so from install of ca-waae-common-11.3.6-1099.i386 conflicts with file from package ca-waae-common-cs2-11.3.6-919.i386

Script or command "rpm -U "/mnt/iso/SDK/Linux/SDK/RPM/ca-waae-common-11.3.6-1099.i386.rpm"" failed with exit code 2.

Reason:         The script or command encountered a problem.

Action:         Find further details in the installation log file /opt/CA/SharedComponents/installer/log/CAWorkloadAutomationAE-SDK.log.

 

error: package ca-waae-common-11.3.6-1099 is not installed

Terminating install. Reverting changes.

Job executed with error: 7

Environment:
Upgrading WCC 11.4 SP4 to 11.4 SP5 on Linux
Cause:

Due to an old installation, package ca-waae-common-cs2-11.3.6-919.i386 had been installed from the CA WAAE 11.3.6 Client DVD

Resolution:

Before attempting the WCC upgrade, delete this old rpm package with:

rpm -e ca-waae-common-cs2-11.3.6-919.i386 --nodeps --noscript