Watchdog warnings

Document ID : KB000006156
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The System Status page in NFA shows errors with services on the NFA components being detected as stopped despite the services actually being running on the server(s), or it shows old CPU utilization or disk utilization data for a server, or shows an IP for a server that is no longer part of NFA.

It may also show an error stating:

Last Polled Status was XX days ago. Either the polling services aren't running or there is no connectivity.

Environment:
NFA standalone or distributed
Cause:

In this case the Watchdog service on the NFA console is having issues polling the NFA components successfully. If it fails to get a successful 'running' state from any of the services, then it will report them as stopped, even if they are actually running on the server.

If there is old data being shown, it is usually because the status tables used by the watchdog aren't updating properly, or have an old entry that isn't being updated since there is a newer entry for that server in the table.

Resolution:

Polling failures

When the watchdog service just isn't able to poll the servers, it's usually because:

  1. Either the community string doesn't match.

  2. There is an SNMP connection failure somewhere

  3. The SNMP service is not running on the target server.

To check the community string used by the watchdog, click on NFA administration at the top, then Watchdog settings on the left. Make sure the community string being shown is correct.

Then go into windows services and check the SNMP service properties on each server, and make sure the string listed on the security tab is the same one as the watchdog. Also make sure that it is set to accept from any host, or if you prefer to define the hosts, that the IP of the NFA master console server is present there.

Once all that has been verified, try restarting the Watchdog service on the NFA master console server. That will force a repoll of the components. Then refresh the system status page, and see if the errors clear.