WA Agent Fails to Start

Document ID : KB000124814
Last Modified Date : 16/01/2019
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Issue:
When attempting to start the WA Agent service, it appears to start but immediately stops. There are no messages in the nohup.stdout or nohup.stderr file indicating a reason for the startup failure.
Environment:
CA WA Agent 11.3 SPX/11.4
UNIX/Linux Only
Cause:
The reason for startup failure was shown in the <AGENT_DIR>/log/runner_os_component.log. The error in this log showed a permission issue with one of the .odb files in the database directory...

Mon Jan 14 11:56:09 2019: Checking database access for database/transmitter_queue_spool_asp_sch.odb failed: No such device or address .Please check permissions
Mon Jan 14 11:56:09 2019: Database check failed

When the agent starts up, it reads the .odb files in the database directory. If it is unable to do so, it will fail to start.
Resolution:
Check the permissions on the .odb files in the database directory and make sure they are all readable. The file owner of these files should be root with a default 755 permission. Also, ensure none have the sticky bit as that is known to cause a problem when the agent starts.