VSE Recorder from DevTest Workstation crashes during VSE proxy passthru-style recording in some conditions

Document ID : KB000111705
Last Modified Date : 21/08/2018
Show Technical Document Details
Issue:
When trying the VSE proxy-passthru style recording from DevTest Workstation which installed in the machine without DNS entry, the VSE recorder is crashed with "Unknown Host" message in workstation.log like below:
2018-07-24 07:53:08,168Z (16:53) [AWT-EventQueue-0] ERROR com.itko.util.swing.UserMessage - yhaoo.co.jp
java.net.UnknownHostException: yhaoo.co.jp
    at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.net.Socket.connect(Socket.java:589)
    at java.net.Socket.connect(Socket.java:538)
    at java.net.Socket.<init>(Socket.java:434)
    at java.net.Socket.<init>(Socket.java:211)
    at com.itko.lisa.web.tcpproxy.TCPProxySocketFactoryImplementation.createClientSocket(TCPProxySocketFactoryImplementation.java:117)
    at com.itko.lisa.web.tcpproxy.HTTPProxyTCPProxyEngine$HTTPProxyStreamDemultiplexer.run(HTTPProxyTCPProxyEngine.java:463)
    at java.lang.Thread.run(Thread.java:745)
Resolution:
Here are the workarounds about this problem.
  1. Add the DNS entry
  2. Add the machine information to hosts file.

However, If you need a patch for this problem(if you do not want to add host information to DNS), then please open a support case to get the solution of this problem. CA support will deliver the patch for this problem.