vmware probe templates not applying

Document ID : KB000004795
Last Modified Date : 14/02/2018
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Issue:

After creating a custom template for the vmware probe and applying it to a vCenter resource, the vmware probe Configure Page from Admin Console is always in a "pending" state.  The custom template is not being applied.  After assuring that the probe is configured with enough memory resources (java_mem_max is set high enough for the monitored resources), verifying the vCenter login credentials are correct and the user has read access on all monitored entities, and all of the vmware probe prerequisites have been met, the log files show errors similar to the following:

[Performance Metric Collection - 28, vmware] Batch fetching of perf metrics failed. Retrying as individual requests
[Performance Metric Collection - 28, vmware] Failed to execute single perf query for entity <entity name>. Invalid property: querySpec.size. Follow VMware KB 2107096 to resolve.

[Data Collector - <resource>, vmware] <monitor name> Datacenter.Local109.Provisioned Space NimQos.Value data not of valid type: java.lang.String () is not valid for QoS Value objects. Sending NULL.

[Data Collector - <resource>, vmware] Inventory update failed. Sending resource alarm
[Data Collector - <resource>, vmware] java.lang.NullPointerException: The source vertex for a CtdRelationship cannot be set to null

Environment:
UIM Server 8.4 and higher with vmware probe version 6.72
Cause:

The issue was with the vCenter resource and not the probe.

 

 

Resolution:

A reboot of the vCenter was required to address the multiple issues with the monitoring of this vCenter.  After the vCenter was rebooted, the custom template was successfully applied and all configured checkpoints were available on the vmware probe's Admin Console Conifgure Page once the monitored resource was successfully discovered by the probe.