Vmware failed to collect data - Alarms not avaiable

Document ID : KB000034064
Last Modified Date : 14/02/2018
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Symptoms:

Vmware alarms appear and disappear very quickly from the Infrasctruture Management console.

 

Environment:

UIM Any Version

Vmware probe any version

 

Cause:

If the vmware probe is configured to collect a large number of metrics, these types of errors can occur if the Java memory limits are not large enough. 

 

Resolution:

The probe's Java memory limits can be configured through the probe's Raw Configure GUI in the options key under the Startup section.

User-added image

The default options value is:
-Xms32m -Xmx512m -Duser.language=en -Duser.country=US

As long as memory is available on the robot where the vmware probe is installed, you can resolve this problem by increasing the Java memory limits.  We typically recommend doubling the values:

-Xms64m -Xmx1024m -Duser.language=en -Duser.country=US

After saving and then applying this configuration change, you must deactivate and then activate the probe to put this change in place.