Visualizer fails when it is launched from Service Desk or when it is tried to be accessed from the Visualizer web client

Document ID : KB000007806
Last Modified Date : 14/02/2018
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Issue:

Visualizer fails when it is launched from Service Desk or when it is tried to be accessed from the Visualizer web client, the following error is prompted:
Authentication failed for the user. Please try again. If problem persists, Please contact administrator.
The visualizer logs show the error bellow:

ERROR LaunchVisualizerImpl.performLoginServiceManaged(129) - AXIS Fault Description ::; nested exception is:
java.net.ConnectException: Connection refused: connect
....

{http://xml.apache.org/axis/}hostname:SERVERNAME

...

Environment:
Service Desk 14.1 or above
Cause:

The error of the logs indicate that Visualizer is unable to connect to the Service Desk SOAP Web services (AXIS), the authentication and load of the data of Visualizer is made via SOAP web services, if there is no connection to this server, Visualizer wont be able to work properly.

Resolution:

1. Ensure that the Service Desk SOAP Web services (AXIS) are up and running by accessing the main page of the web services from the Visualizer server.
servicedesk_hostname:servicedesk_port/axis

2. Then verify that the same url was configured in the following file in the Visualizer server:
..\CA\Service Desk Manager\bopcfg\www\CATALINA_BASE_VIZ\webapps\CMDBVisualizer\WEB-INF\classes\com\ca\cmdbvisualizer\config\cmdbvisualizerconfig.properties

Specifically the line that includes USD_WEBSERVICE_URL=http://

The URL should match with the Service Desk host name and the port.

Note: In the case that the URL does not match and the variable needs to be edited, the Service Desk services need to be restarted.