Virtual Services are not responding.

Document ID : KB000015590
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

 

When you deploy a VS, the VSname.mar file and VSname.mar.tracking folder are created automatically in DevTest_Home/vseDeploy/VSE_2013 folder. These files can be corrupted for some reason and VSE server may not respond.  This document shows how you can restore your VSE server when there is a file corruption. 


 

Question:

DevTest VSE service is automatically stopping.  It is not responding.  We are unable to deploy or test any services in VSE. 

 

Environment:
All supported DevTest releases.
Answer:

 The VSE server would not start properly because there seemed to be a corruption in a tracking folder or mar file under the DevTest/vseDeploy/vse_2013 folder.

 

This is what you can do when that occurs:

1. In your DevTest install folder where VSE is running, rename the /vseDeploy/VSE_2013 to /vseDeploy/VSE_2013_old.

2. Restart the VSE Service and  a new VSE_2013 folder will be created under /vseDeploy.

3. Copy only the .mar files from /vseDeploy/VSE_2013_old to /vseDeploy/VSE_2013.  If there is any .mar file that has 0kb in size do not copy that file.  It might be corrupted.

4. The Server Console ( for versions prior to DevTest 9.5.0) or the Portal should show the deployed VSM's after the above change.

5. For the corrupted mar files, delete those .mar files and redeploy the VSM/VSM's again and it would create new .mar files in VSE_2013 folder.