[VMTP] Virtual Multi-Port Monitor shows "No Valid Adapters Found" Error during upgrade

Document ID : KB000124098
Last Modified Date : 03/01/2019
Show Technical Document Details
Issue:
During the VMTP 10.6 -> 11.0 upgrade, the following error is displayed:

12/14/16 10:28:06.182463 | 17780 | ERROR | SRV | 4-8450e1 | Error during adapter discovery: No valid adapters found 
12/14/16 10:28:06.182470 | 17780 | ERROR | SRV | 4-8450e1 | ** 
12/14/16 10:28:06.182474 | 17780 | ERROR | SRV | 4-8450e1 | * No adapters located in the system * 
12/14/16 10:28:06.182478 | 17780 | ERROR | SRV | 4-8450e1 | * Please check that the driver is loaded. * 
12/14/16 10:28:06.182483 | 17780 | ERROR | SRV | 4-8450e1 | ******* 
12/14/16 10:28:06.182490 | 17780 | ERROR | SRV | 4-8450e1 | ****** 
12/14/16 10:28:06.182495 | 17780 | ERROR | SRV | 4-8450e1 | * Something failed during init. * 
12/14/16 10:28:06.182499 | 17780 | ERROR | SRV | 4-8450e1 | * Please check the complete log for more info. * 
12/14/16 10:28:06.182503 | 17780 | ERROR | SRV | 4-8450e1 | 
Environment:
CentOS 6.7+
Cause:
In VMTP 11.0, we migrated our code to run the latest 3G version of Napatech’s API. It turns out that the 3G API, driver, and service are not compatible with all firmware out there. This is especially true for older installations, whose firmware has never been updated. The MTP releases would provide updated firmware to MBX to install on cards, but upgrading the firmware was never part of the MTP software update code. 
Resolution:
A firmware upgrade for the VMTP's Napatech card is required to remedy this issue.

Please contact CA Support for the firmware packages and installation instructions.