Virtual Appliance 12.6.8 Database password expiring

Document ID : KB000013038
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

In Identity Suite 12.6.8 Virtual Appliance, the password for the database has expired. This is the error I see:

"Caused by: java.sql.SQLException: ORA-28001: the password has expired"

There are no credentials to access the database to resolve this. What are the properly steps to resolve this issue?

Answer:

All Identity Suite frontend applications will fail to (re)start with the following error message in the application server log:

Caused by: java.sql.SQLException: ORA-28001: the password has expired

 

CA has released a hotfix that removes the expiration, please find it attached to this doc and also under the following FTP site:
ftp://ftp.ca.com/pub/CAIdentitySuiteVA//cumulative-releases/12-6-8-cr2/Hotfixes/cavapp-hotfix-20161028-oracle-db-expiry.tgz.gpg

 

To install the hotfix:

  1. use SCP software to copy it to the vApp server running the embedded database 
  2. Login to the vApp server running the embedded database using SSH/CLI console as the config user
  3. Run the following command: upgrade_vapp <patch_filename>
  4. If any Wildlfy-based application could not be started before installing the hotfix due to the password expired - start it by running the relevant alias on the relevant vApp server:
    To start Identity Portal: start_ip
    To start Identity Manager: start_im
    To start Identity Governance: start_ig

 

Hotfix:

cavapp-hotfix-20161028-oracle-db-expiry.tgz.gpg.zip

 

This issue is resolved starting from vApp 12.6.8 CR2 and also on vApp 14.0. There are no longer password expirations for the database.

File Attachments:
TEC1695352.zip