Vertica cannot load library file

Document ID : KB000109680
Last Modified Date : 03/08/2018
Show Technical Document Details
Issue:
After upgrading a number of 3.5 (and earlier) CA PM boxes to CA PM 3.6
there is a Vertica library issue in the upgrade process. The following error
message appears in the vertica.log file:

2018-07-18 23:17:54.842 CatchUp:7ff653fff700-a00000003a92a5 [Recover]
<WARNING> Cannot load library file
[/opt/application/CA/data/catalog/drdata/v_drdata_node0001_catalog/Libraries/029fce8e99e6e9befaf82df7cc90e
18600a0000000000400/HdfsSource_029fce8e99e6e9befaf82df7cc90e18600a0000000000400.so],
It was built with incompatible SDK Version: 8.1.0, expected version: 9.0.1

2018-07-18 23:17:55.669 CatchUp:7ff653fff700-a00000003a92a5 [Recover]
<WARNING> Error during setting up function, message:  The library was built with an incompatible SDK
Environment:
CAPM 3.x
Cause:
Unused library for hadoop
Resolution:
Simply drop the library by doing the following:

1. Launch adminTools
2. Connect to the database
3. Run the following query: drop library HdfsSource cascade; 
 
Additional Information:
This warning does not seem to impact functionality but dropping the library will prevent it from being loaded