Version mismatch error message after DB2 upgrade.

Document ID : KB000007292
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After the DB2 upgrade, even if the correct SSIDVER and SSIDMODE has been set into SETUPXX member of CDBAPARM library, starting the CA DB2 TOOLS the version is still shown as V10 NFM, whereas the DB2 system is V11 NFM.

Customer is getting error:

RC=209, RCODE=0000 DB2 CONNECT ERR:SSID V10NFM   . VERSION mismatch 

SSIDVER=V11

 

Environment:
CA Database Management Solutions for DB2 for z/OS 18.0 - 19.0
Cause:

CA Database Management Solutions for DB2  compare the SSIDVER and SSIDMODE to the DSNHDECP member in the SDSNEXIT DB2 library.

This information must match what you specified in the SETUPXX parmlib member.

Resolution:

In order to upgrade to New DB2 Versions or Modes, use the following procedure :

Update the DB2 subsystem version (SSIDVER) and migration mode (SSIDMODE) on the SETUPXX parmlib member. The migration mode must be the same as the DB2 runtime environment.

Update the DB2 load library information.

Regenerate and execute the following DB2 catalog customization tasks:

    . Compare DB2 objects.

    . Create required DB2 objects.

    . Bind product packages and plans

Moreover, ,after setting SSIDVER= V11 in your SETUPXX, you can check, using the TSO ISRDDN command from the DB2 Tools MAIN MENU, if the SDSNEXIT we are picking up is the one in SETUPXX.

Then on member DSNDHECP if you find either of the following: V11R1M0 or V10R1M0, you can verify the actual version.  

Additional Information:

See Upgrade to New DB2 Versions or Modes Chapter in CA Database Management Solutions for DB2 for z/OS - 18.0 documentation.