VAIM installation cannot authenticate against SQL Express.

Document ID : KB000067703
Last Modified Date : 25/07/2018
Show Technical Document Details
Introduction:

Problem

VAIM installation cannot proceed past Database configuration dialogue box, even though the correct connection information and credentials are being supplied.

 

Management Database:  Failed to establish connection to SQL Server Please verify that all information is correct, that the remote SQL Server instance has TCP/IP enabled, and that it is listening on the port specified.

The error received was:

The TCP/IP connection to the host FLABR02-U161719, port 1433 has failed. Error: "Connection refused: connect. Verify the connection properties, check that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port, and that no firewall is blocking TCP connections to the port.".

 

SQL.PNG

 

Cause:

 

On SQL Express installations the default configuration is set to use dynamic ports, and not SQL Server default listening port 1433.

 

Resolution/Workaround:

 

 

 1. Launch SQL Server Configuration Manager.

 

 2. Select SQL Server Network Configuration (32 Bit) > Protocols for SQL Express.  

 

 3. On the right hand pane click on TCP/IP and select enable, then select properties.

 

SQL3.PNG

 

 

 3. On IP Addresses Tab Scroll all the way to the bottom.

 

 4. Under IPALL Make Dynamic Ports field NULL (Empty).  

 

 5. Set TCP Port to 1433.

 

 6. Once this change is made recycle SQL Server Service.

 

 7. VAIM will now be able to authenticate into the SQL Express instance.

 

 

SQL4.PNG

 

 

 

 

 

Instructions:
Please Update This Required Field