UVMS java process using 100% cpu: impossible to login / use the command line

Document ID : KB000086955
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
The only significant error that can appear on the uvserver.log is the following:

############## 
|ERROR| request-worker-10939 | com.orsyp.central.aspect.DAOServiceCheckerAspect | Transaction duration: 01:23:25.248 
com.orsyp.central.aspect.DAOServiceCheckerAspect$LongTransactionWorning: Long transaction detected. Transaction duration: 01:23:25.248 
############## 

Patch level detected:Univiewer Management Server 6.2.00
Product Version: Dollar.Universe 6.2.0

Description :All of a sudden,the UVMS java process is using 100% CPU and it is impossible to connect / use the command line.
Environment:
OS: All
Cause:
Cause type:
Configuration
Root Cause: The issue looks related to an issue with the Cluster Active / Active and the fact that both members share the same Database, at some point, a query was done by an user on one of the database tables and this transaction kept on running indefinitely.
Resolution:
In order to restore the service simply restart the Univiewer Management Server.
In case of an UVMS cluster Active / Active, you should only have one UVMS started in order to be on an Active / Passive configuration.

Fix Status: No Fix
 
Additional Information:
Workaround :
N/A