UVMS cannot be started after a Windows update

Document ID : KB000084383
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
Connection refused: connect :

Patch level detected:Univiewer Management Server 6.5.01
Product Version: Dollar.Universe 6.5.01

The Univiewer Management Server (UVMS) XXXX_MgtServer service on Local Computer started and then stopped.

Some services stop automatically if they are not in use by other services or programs.

Following a Windows update, Univiewer Management Server (UVMS) does not startup.

When the service XXXX_MgtServer is started manually via the Windows Service Manager, the above error is present.
Environment:
OS: Windows
OS Version: All Windows
Cause:
Cause type:
Configuration
Root Cause: After an update to Java, the old Java directory may be erased.
The link between the UVMS and Java in the unienv.bat file becomes obsolete.
This change only becomes apparent after Windows has been restarted in the event of a Windows update.
The unienv.bat file no longer contains correct links to Java and must be updated with the correct information.
Resolution:
  • Check the Java version with the following command run at the command prompt: java -version
  • Edit the unienv.bat file and check that the line referencing Java reports the same Java version.
  • You need to have something resembling this: set JAVA_ORSYP="C:\Program Files (x86)\Java\jre1.8.0_65"
  • If not, please update the file with the correct path to the Java version used on this system.


Fix Status: No Fix

Additional Information:
Workaround :
N/A