UVC: Cannot import autopatch packages

Document ID : KB000106034
Last Modified Date : 25/09/2018
Show Technical Document Details
Issue:
After several unsuccessful attempts to upgrade UVMS it is impossible to Import Autopatch packages into UVMS via UVC or via command line (uniimp pkg).
This used to work fine before.

Example of the operation and errors encountered:

D:\uvms\app\bin>uniimp PKG -pkgfile D:\temp\DUAS-UPDATE-WINDOWS64-6.8.24.unipkg -pkg DUAS-UPDATE-WINDOWS
64-6.8.24 -pkgproduct DU -pkgtype AUTOPATCH -override
UniViewer Management Server environment loaded.

Importing package from D:\temp\DUAS-UPDATE-WINDOWS64-6.8.24.unipkg ...
Import package error: ServerException - send: (see log for more details)


When looking into uvserver.log:
|ERROR| request-worker-x | com.orsyp.central.server.DispatchHandler | Handle creation errorĀ 
java.io.IOException: The system cannot find the path specifiedĀ 
Environment:
UVMS Server on Linux or Windows
Cause:
The subfolders autopatch and temp were missing into the folder data of the UVMS
Resolution:
The creation of the subfolders autopatch and temp inside the folder data fixes the issue.