UVC: Access Denied when modifying Node Settings

Document ID : KB000121481
Last Modified Date : 22/11/2018
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Issue:
Sometimes, when trying to modify the Node Settings of a node where the user has "Administrator" permissions, UVC fails to perform the requested operation and displays the following popup-error

"The access is denied, usually due to security constraints or license restrictions"
"L'accès est refusé, à cause de contrainte de sécurité ou de restrictions de license"


Most strange thing is that sometimes it will work if we retry again later on.
Environment:
Univiewer Console and Dollar Universe 6 nodes
Cause:
Probably a corrupted UVC Java Cache, if the trace 0,SECURITY is enabled in the Dollar Universe node, we see the following in universe.log:
|TRACE|X|IO |pid=p.t| o_check_security | Security denied (found in cache) 
|INFO |X|IO |pid=p.t| owls_check_security | Security denied for OBJ(NODE_SETTINGS) OPER(USE_WITHIN_LAUNCH) 
|INFO |X|IO |pid=p.t| owls_check_security | ID() 
Resolution:
In order to fix the issue, please clear Java Cache in the Windows server where UVC is launched, to do so:

Click Start > Control Panel. Locate and double click the Java icon in the Control Panel.
Click Settings under Temporary Internet Files.
Click Delete Files. Select all boxes and click OK on Delete Temporary Files window.
Click OK on Temporary Files Settings window.
Click OK to close the Java Control Panel.

Empty Temporary Java Files

Then Close and Reopen again UVC, the issue should not occur anymore.