USM Slow due high number of alarms history at the USM

Document ID : KB000004483
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

USM seems loading very slow after some time, even reports are being processed very slow

Environment:
UIM 8.3.1 or later versions
Cause:

USM Slow due high number of alarms history at the USM

Check with this queries if you have a large number of alarms like above 80.000 into the DB on any of this Tables:

 

select count(*) from nas_alarms;

select count(*) from nas_transaction_log;

select count(*) from nas_transaction_summary;

Resolution:

 
CREATE INDEX IDX_NAS_TRANS_SUM04 ON NAS_TRANSACTION_SUMMARY (CLOSED);


Restart Trellis Probe

Additional Information:

If just this procedure not help in the USM performance, please take a look at all this procedures to improve the DB performance for reference:

http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1405477.html

 

Indexing:

https://docops.ca.com/ca-unified-infrastructure-management-probes/en/alphabetical-probe-articles/data_engine/data_engine-versions-8-0-8-3/v8-0-data_engine-im-configuration

o Check the row count for maintenance_* tables and see if it has > 500 records.

This may contribute to performance problems. These tables may need to be truncated.

select count(*) from MAINTENANCE_SCHEDULE select count(*) from MAINTENANCE_SCHEDULE_MEMBERS select count(*) from MAINTENANCE_WINDOW

Fragmentation:
http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC000004098.html

Best Practice:
http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC000002592.html

Search for Bad/Special characters:
http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec000005283.html

UMP Debug steps:
http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec000003890.html