USM portlet pops up unkown error and fails to start

Document ID : KB000007718
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:
  • In USM portlet error message is observed and USM fails to load the information.
  • Other UMP portlets work correctly.

An unknown error has occurred.

Refreshing your browser may resolve the issue.

Details:

com.firehunter.ump.exceptions.DataFactoryException : com.firehunter.ump.exceptions.DataFactoryException: Column 'CM_CONFIG_ITEM_TO_MASTER.master_id' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.

Please check the log for more information.

Stack Trace:

(1) error, com.firehunter.ump.exceptions.DataFactoryException: Column 'CM_CONFIG_ITEM_TO_MASTER.master_id' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.: Column 'CM_CONFIG_ITEM_TO_MASTER.master_id' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.

 

Portal log

7 Aug 2017 15:26:39,719 ERROR [DataFactoryException:102] Column 'CM_CONFIG_ITEM_TO_MASTER.master_id' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.

07 Aug 2017 15:26:39,721 ERROR [DataFactoryException:104] 

07 Aug 2017 15:26:39,721 ERROR [DataFactoryException:107] com.microsoft.sqlserver.jdbc.SQLServerException: Column 'CM_CONFIG_ITEM_TO_MASTER.master_id' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.

 

Environment:
UIM 8.51
Resolution:

Wasp log

Aug 07 16:04:58:949 INFO  [dashboard-akka.actor.default-dispatcher-5, com.nimsoft.nimbus.probe.service.wasp.Wasp] Failure retrieving 'get_monitoring_mode' from mpse at '/xxxx/xxxx/xxx01/mpse'. Defaulting isSnap = true

 

 

 

  • Check if the mpse probe is functioning correctly .
  • Can delete and redeploy the mpse probe if this is not starting up correctly which should resolve the issue 
  • UMP wasp probe restart might be required in some cases