USM just stays on loading window after upgrade to UIM 8.51

Document ID : KB000006484
Last Modified Date : 14/02/2018
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Issue:

After upgrading to 8.51. I log into UMP and USM just shows this screen and never gets past it. I do not get any error message.

 

usm1.png

Cause:

Alarm management has been moved to EMS in UIM 8.51.

To validate this issue is being caused by EMS, change the url for your ump to the following:

http://ump.mycompany.org/user/administrator/home#

to

http://ump.mycompany.org/usm/jsp/diag.jsp

After the session section you will see these entries:

If EMS is the issue it will look like this:

usm4.png
usm3.png

This is a normal entry:


usm5.png

Notice how the bad entry does not have the alarm messages above MyUsr.

 

 

 

Resolution:

To resolve this issue.

rdp or ssh to the primary uim.

Launch Infrastructure manager (IM) or admin console.

  1. copy the ems folder to a backup location.
    On Windows the path is C:\Program Files (x86)\Nimsoft\probes\service
    On Linux the path is /opt/nimsoft/probes/service
  2. delete the ems probe from IM or admin console
  3. delete the ems folder from the OS
  4. deploy ems from the archive
  5. start ems
  6. log out of UMP and back in. There is no need to restart wasp.

If you had customization in EMS, you can copy the entries from the backed up ems folder. If USM stops working again when the customization is added, then  remove the customization, and call in a new case to support.

 

 

Additional Information:

Article is valid as of May 3, 2017