Using XPSSweeper as an option to fix the AgentInstance@: Object's Globally Unique ID (GUID) has not been set error.

Document ID : KB000044597
Last Modified Date : 14/02/2018
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Issue/Problem/Symptoms: 

Your getting the error [Validate][ERROR][sm-xpsxps-03310] CA.SM::AgentInstance@: Object's Globally Unique ID (GUID) has not been set

 

Environment:  

 

Linux/Windows/Unix

Cause: 

 

You are probably getting the error "[Validate][ERROR][sm-xpsxps-03310] CA.SM::AgentInstance@: Object's Globally Unique ID (GUID) has not been set"

because you are not running the XPSSweeper to remove stale policy objects regularly. Stale policy store objects are probably causing the message above

 

Resolution/Workaround:

 

Run XPSSweeper at the command prompt on the policy server to remove stale policy objects as a probable solution to this error message above

 

Additional Information:

 

To remove stale policy objects regularly, you should configure the Policy Server to run the XPSSweeper tool every 24 hours. If the XPSSweeper utility does not run regularly, the Policy Server can have trouble starting. 

 

Too many stale objects in the policy store can cause many errors including the one covered in this knowledge document.

For further info on running the XPSSweeper to remove stale policy objects regularly, please see the link below.    

https://docops.ca.com/ca-single-sign-on-12-52-sp1/en/administrating/policy-server-tools/xpssweeper#XPSSweeper-RemoveStalePolicyObjectsbyRunningXPSSweeperRegularly