user synchronization between pm 3.5 and cabi not working correctly

Document ID : KB000071354
Last Modified Date : 19/02/2018
Show Technical Document Details
Issue:
We recently upgraded our PM installation from version 3.2 to 3.5. After that we refreshed the integration between PM and CABI and configured the user synchronization as described in

https://docops.ca.com/ca-performance-management/3-5/en/integrating/integrate-ca-business-intelligence/install-ca-business-intelligence-reports-and-dashboards

We have usernames in the format xx@bb.com as User principal name in Active directory. As there is a '.' (dot) in the username , it does not get synched over to CA Business intelligence server.
 
Environment:
CA Performance Management 3.5
CA Business Intelligence 6.3
Cause:
User names that contain the following special characters are not synchronized with the CABI Server:
 . , \ | ` " ' ~ ! # $ % ^ & [ ] * + = ; : ? < > } { ) ( / including spaces.
Resolution:

Please request for fixes provided on Defects DE345805  and DE345805 to support '@' and '.'.

Additional Information:
Defect DE399933  with CA Business Intelligence team
Defect DE345805  with Performance Management Engineering team