User gets BASEC003 trying to access /a function in Netmaster or SOLVE

Document ID : KB000112111
Last Modified Date : 24/08/2018
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Issue:
In a NetMaster or SOLVE region, a user or group of users is seeing this message
BASEC003 USER xxxxxxx NOT AUTHORIZED TO yyyy

This can manifest in different ways:
- a user (or group of users) has access to a function on one region but not another while UAMS and external security are the same.
- a user (or group of users) is missing access to a function after an upgrade with no changes to security.
- other scenarios may be possible.
 
Environment:
All SOLVE and Netmaster products
Cause:
NPF security  is different or missing
Resolution:
1. Check page 5 of the UAMS definition for affected users to see if any of these fields are populated
    NPF Resource List Member .....                                         
    NPF Command Member ...........                                               
    NPF Message Member ...........
         
 
2.  If so, ensure that any listed members are contained in your TESTEXEC.

3. If upgrading or building a region on a new system,, check your old TESTEXEC for any members starting with $RMS* and ensure they are copied to your new TESTEXEC

4. Check the NPTABLES DD statement in your RUNSYSIN and compare with the prior release or working region.
    The default definition contains
     DD=NPTABLES,BLKSIZE=32720,DISP=SHR,DSN=hlq.TESTEXEC
         DD=*,DISP=SHR,DSN=hlq.CC2DEXEC 

     Perhaps you have additional libraries containing custom $RMS* members that need to be added.

If your problem still persists please contact CA Customer Support.