Agile Central: Excel - Can't use the add-in. Getting: "This add-in is incompatible with Data Execution Prevention mode and should be disabled or upgraded to latest version" error

Document ID : KB000101636
Last Modified Date : 15/06/2018
Show Technical Document Details
Question:
When opening the Excel Add-in , it won't open. This error is displayed:
What does this error mean? How can we fix it?

User-added image
Answer:
Data Execution Prevention, otherwise known as DEP, is a set of technologies incorporated into Windows XP SP2 and later that prevents code from being run in certain regions of memory that are not authorized. You are receiving this error because your Agile Central Excel add-in isn't trusting the add-in.

For Office 2010 (that is Excel 2010) you can make this trust in excel itself. See:
https://support.office.com/en-us/article/why-is-my-add-in-crashing-1e02d873-04c8-4ecd-ac63-8f18507a3870?ui=en-US&rs=en-US&ad=US

For Office 2013, you can no longer create this trust in Excel. You will need to create it in the DEP general definitions. Unless you opt to use DEP only for essential Windows programs and services, then you'll need to allow your Excel program by creating an exception. See:

User-added image

User-added image


For a more detailed explanation on DEP, see:
https://www.online-tech-tips.com/windows-xp/disable-turn-off-dep-windows/

https://support.office.com/en-us/article/why-is-my-add-in-crashing-1e02d873-04c8-4ecd-ac63-8f18507a3870?ui=en-US&rs=en-US&ad=US
Additional Information:
More information on the Excel Add-in: 
https://help.rallydev.com/import-export-excel-addin

Excel Add-in's installation guide:
https://help.rallydev.com/rally-add-excel-installation-user-guide

Additional Knowledge Articles on the Excel Add-in:
https://support.ca.com/us/product-information/ca-agile-central.html?q=excel&type=ALL