Use Postgres 9.4 for CA APM 10.7

Document ID : KB000115142
Last Modified Date : 01/10/2018
Show Technical Document Details
Question:
Is it possible to install the Postgres 9.6.2 schema embedded in the product APM 10.7 in the Posgtres database version 9.4 (which is not the standard)
Answer:
PostgreSQL 9.4.10 + APM 10.7 on RHEL 6.x. This configuration has been validate and certified
EM able to connect postgres & generate data without any errors. 

Covered below scenarios: 
• Installed both EM & postgres on RHEL 6.x 
• Postgres installed from postgre 9.4.10 source code 


To install DB & schema we need scripts which will be located under <<EM_HOME>>/install/database_scripts/unix (see scripts.zip attached)

after installing we have to replace existing pg_hba.conf,postgresql.conf under <<pg_home>>/data/ with the attached files .

Few properties  have to be modified in pg_hba, postgresql.conf files as per APM require
File Attachments:
Scripts.zip