UPM Installation hangs at around 70%

Document ID : KB000020532
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

At the end of UPM installation, setup is hanging like in this screenshot:

Figure 1

In %TEMP%\PatchManagerSetup.log the last lines are lines like:

14:24:54 Launching CreateModifyShortcut

14:24:54 Command is: cmd.exe cscript.exe /c C:\Users\caadmin\AppData\Local\Temp\{E7135B45-D2D0-42BA-A8B8-EBBD7CA64B7B}\CreateModifyShortcut.vbs "C:\PROGRA~3\MICROS~1\Windows\STARTM~1\Programs\CA\CAPATC~1\RELEAS~1.LNK" "D:\PROGRA~1\CA\UPM\doc\ITCM_R~1.PDF" "C:\Users\caadmin\AppData\Local\Temp\PatchManagerSetupCmd.log"

Normally the next line which should appear is:

14:49:18 UPM is successfully registered to CIC

Solution:

UPM setup is hanging when trying to register UPM application in the CIC.
UPM is executing this command and wait for it:

util -R UPM 682DCD15-5C94-4321-842D-E3944D3CA000 PMUPM-00000-00000-00001 upmuser_group

Due to problem in CIC, this command is hanging.

This problem could be caused by:

  • A java.exe process for last execution of CIC is hanging in memory.
  • CIC is not correctly configured. For example no proxy Web has been set.

Solution 1:
---------------

  • Check if you have a running process java.exe for CIC.

    You could check it by executing this command line:

    wmic PROCESS get Processid,Caption,Commandline | find /I "java.exe" | find /I "CIC"

    Figure 2

    If a process is found, check in the CIC.log (C:\Program Files\CA\SC\CIC\logs) if it is frozen or if it s running correctly.

    If it looks frozen (it has started for several hours and no new logs are generated), then kill it by using the PID returned by the command line.

    And retry UPM installation

Solution 2:
---------------

If solution 1 is not applicable (there is no frozen CIC java.exe process), then maybe CIC is not correctly configured.

You could verify this by executing this
cd C:\Program Files\CA\SC\CIC\bin
util -R UPM 682DCD15-5C94-4321-842D-E3944D3CA000 PMUPM-00000-00000-00001 upmuser_group

and check that command util is looping and there are a lot of errors in file C:\Program Files\CA\SC\CIC\logs\CIC_Util.log

As workaround we could do this:

  • Rename the registry key HKLM\SOFTWARE\ComputerAssociates\CIC as CIC.TEMP
    (HKLM\SOFTWARE\Wow6432Node\ComputerAssociates\CIC on 64 bits machine)

  • Try again the UPM installation

  • Once installed, rename the registry key to original name HKLM\SOFTWARE\ComputerAssociates\CIC

  • Later when CIC will be correctly configured following command should be executed:

    cd C:\Program Files\CA\SC\CIC\bin
    util -R UPM 682DCD15-5C94-4321-842D-E3944D3CA000 PMUPM-00000-00000-00001 upmuser_group