Upgrading to 4.3.2 fails. Unable to rollback the installation.

Document ID : KB000007058
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

A failure will occur when upgrading to Process Automation  04.3.02 if in a previous version of  Process Automation a customer has configured both the  “Network Utilities” and “File Transfer” modules (or connectors), at the domain level. This problem will NOT be manifest if just the “Command Execution” module has been previously configured.  The upgrade will not complete and you will be unable to rollback to the previous release which could leave your orchestrator in a degraded state.

 

Cause:

Issue with the domain.xml for C20Service.  This is now listed as a known issue to be fixed in the installer for a later release of Process Automation.

 

https://docops.ca.com/ca-process-automation/04-3-02/en/release-notes/known-issues-in-ca-process-automation-r-04-3-02

 

 

Resolution:

Before you upgrade CA PAM to CA PAM 04.3.02, follow these steps:

  1. Take the backup of the existing domains.xml in the CA PAM installation folder, <CA/PAM/server/c2o/.config>.
  2. In the domain.xml file, comment the entire <C2OService> with the ServiceName as FTPServices at the domain level.
  3. Save the domain.xml file.
  4. Run the CA Process Automation Installation Wizard to the upgrade CA Process Automation to Version 04.3.02.
  5. (Optional) After successfully upgrading to CA Process Automation 04.3.02, uncomment the entire <C2OService> that is commented in Step 2 and save the domain.xml file.
  6. Start the CA Process Automation Server.

 

Example:

Comment out from <C2OServices> to </C20Services> 

<!--C2oService>

</C2OService> -->