Upgrading to 14.1 GA failure.

Document ID : KB000039376
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue:

When performing an upgrade to 14.1 the following error occurs:

'Cannot find $NX_ROOT. Variable not set.'

Resolution:

When upgrading to 14.1 and the following error is seen:

'Cannot find $NX_ROOT. Variable not set.'

This can be resolved by performing the following steps:

-Go to your main drive where Windows itself is installed. This is typically your C:\ drive by default.

-Once you are in your default Windows drive go to your Windows folder.

-Once there scroll down until you see a Paradigm.ini file. Please open it in a notepad file.

-Once the paradigm.ini file is open you can change the $NX_ROOT and $NX_LOCAL to point to where you have service desk installed.

  • Ex: NX_ROOT=C:/PROGRA~2/CA/SERVIC~1
  • Ex: NX_LOCAL=C:/PROGRA~2/CA/SERVIC~1

-Once the paradigm.ini points to the correct directories for your $NX_ROOT and $NX_LOCAL save it and close out of the file and try the upgrade again. This should help fix the upgrade error that was being received.