€œUpgrading the NAC fails with error "Checking for running jobs..Active jobs were found, Please stop all active jobs and continue the upgrade process"

Document ID : KB000005078
Last Modified Date : 14/02/2018
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Issue:

Upgrading Release Automation may fail even though all steps as listed in https://docops.ca.com/ca-release-automation/6-1/en/installation/upgrade-ca-release-automation were followed.

In dashboard no processes under running state, yet while running the upgrade following error shows up:  "€œChecking for running jobs..Active jobs were found. Please stop all active jobs and continue the upgrade process"

Environment:
Release Automation management server (NAC) to be upgraded from 5.5.x to 6.x
Cause:

Even though the dashboard does not list any running or long running jobs, there may still be jobs within the database that prevent the upgrade from succeeding.

Resolution:

*Login to the JMX Management Console: http://<NAC IP/FQDN>:20203/ (it will prompt for a username and password, both of which are, by default, "nolio"). 

*From the "Server view" tab, locate the "Domain: noliocenter" category. 

*Click on "noliocenter:type=ExecutionCaches" option. It will then open MBean "noliocenter:type=ExecutionCaches" under the "Mbean view" tab. 

*Under the "Operations" category, click the "Invoke" button for the "showJobsCache" option. If there are any current deployments, they will be listed here. Various details about each deployment will show, including the Job ID, which should be noted down. 

* From the "Server view" tab, return to the "Domain: noliocenter" category. 

* Select "noliocenter:type=info" to open it under the "Mbean view" tab. 

* Under the "Operations" category, enter the Job ID in the field for the "Parameters" option for "removeProcessRun". 

* Click the "Invoke" button to kill the process.

Additional Information:

Following techdoc contains a checklist to go through before starting the upgrade, in case other problems are met during the upgrade process:

https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec1194435.html