Upgrading process automation to 4.3.03 could not create file

Document ID : KB000111054
Last Modified Date : 14/08/2018
Show Technical Document Details
Question:
Upgraded to 4.3.03 and during upgrade message e:\ca\pam\server\c2o\ext-lib\jna-3.4.0.jar could not create this file. Shall I try again? I clicked yes same error message then I clicked no and continued on. Everything appears to be working fine. Just wondering if that is a big deal
Environment:
Windows server installation
Answer:
The jna-3.4.0.jar file is the Java Native Access reference and is required.
This file has been in place since at least version 4.2.2 of CA Process Automation, so the error message is just a warning about attempting to overwrite it. 
As long as the jar file exists in the ext-lib folder, the install is complete regarding that. 
Make sure when an upgrade is being run in a Windows environment, that when the .exe file is selected a right click is done and Run As Administrator is selected.