How to Upgrade Harvest Remote agent and Workbench

Document ID : KB000109282
Last Modified Date : 19/09/2018
Show Technical Document Details
Introduction:
For the upcoming R13.3 implementation, I have the following scenario that I need to understand if there are compatibilty issues?
Broker running R13.3,
Workbench running R12.6
Remote agent running R12.6.
User establishes a remote agent connection in their Workbench and checkout/checkin to the remote agent AIX server.
Question:
Does the remote agent AIX server need to be updated to R13.3 also?
Will Harvest R12.6 workbench be able to establish the remote agent connection to the R13.3 remote agent?
Environment:
CA Harvest SCM v13
All platforms
Answer:
When you upgrade, you’ll need to do the server first, and then the clients later.
A 12.6 client can work with a v13 server, but the v13 client doesn’t work with a 12.6 server.
Additional Information:
Installation and upgrade information can be found in the “Implementation Guide”.
Here’s the main link to the documentation for V13: https://docops.ca.com/ca-harvest-scm/13-0/en.
There is a chapter there on “Installing” and another chapter on “Upgrading”.
This is where you’ll find information about how to install and how to upgrade.