UpgradeReadinessCheck Tool is not Working

Document ID : KB000125252
Last Modified Date : 24/01/2019
Show Technical Document Details
Issue:
When we attempt to run the UpgradeReadinessCheck tool on 12.8.1, we see the following error:

INFO: Starting UpgradeReadinessCheck .....
ERROR: Connection to Policy Store failed.

 
Cause:
The tool is only able to connect to the default Policy Server authentication port (44442).  The 12.8.1 version of the tool, as well as lower versions have no way to connect to a non-default authentication port.
Resolution:
This will be fixed in a future release.  A Development Fix is available for customers who either cannot wait for a released version or cannot temporarily switch to the default authentication port (44442) as a workaround.