'Upgrade the CA API Gateway database' Menu shows 'Database upgrade not required' after 9.2 upgrade.

Document ID : KB000005751
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The 'Upgrade the CA API Gateway database' menu shows 'Database upgrade not required' after the 9.2 upgrade (CA_API_Gateway_v9.2.00) has been successful finished.

Cause:

The problem was based on a disk space issue that leave the required 9.2 Platform update (CA_API_PlatformUpdate_64bit_v9.2.00-RHEL) installation fail.

After more disk space has been allocated, the 9.2 Platform and Software update finished successful but it returned the 'Database upgrade not required'.

This is wrong, the upgrade requires a database upgrade otherwise the ssg will not start properly.

Resolution:

Open a privileged shell.

Remove any patch status files: mv /opt/SecureSpan/Controller/var/patches/*.status /tmp.

Reload and install the 9.2 Platform update (CA_API_PlatformUpdate_64bit_v9.2.00-RHEL) via the Patch Management Menu.

Reload and install the 9.2 Application update (CA_API_Gateway_v9.2.00) via the Patch Management Menu.

Run the database upgrade via 'Upgrade the CA API Gateway database' Menu.

 

 

Additional Information:

Related Knowledge Base Article:

"Database upgrade not required" after applying API Gateway Application Update