Upgrade fails with error: : ORA-01400: cannot insert NULL into ("PPM"."CLB_NOTIFICATION_ASSOCS"."NOTIFICATION_DEF_ID")

Document ID : KB000100795
Last Modified Date : 11/06/2018
Show Technical Document Details
Issue:
Full Error message:
 
6/06/18 3:03 PM (ExecTask) Starting seeding instance of :: Tomcat access log import/analyze
6/06/18 3:03 PM (ExecTask) com.niku.dbtools.ant.ExecutableException: c:\ppm14303\upgrade\15.3.0\component\postupgrade\content.xml:52: java.lang.Exception: Error processing xbl 'scheduler/postSchedulerProperties.xbl'. Message(s): com.niku.union.persistence.PersistenceException:
6/06/18 3:03 PM (ExecTask) SQL error code: 1400
6/06/18 3:03 PM (ExecTask) Error message: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-01400: cannot insert NULL into ("PPM"."CLB_NOTIFICATION_ASSOCS"."NOTIFICATION_DEF_ID")
Cause:
 
The job definition for job Tomcat access log import/analyze with ID log_import_analyze_job has been made inactive.  
Raised as defect DE41867 Deactivating the Tomcat access log import/analyze in UI can fail the upgrade with error: ORA-01400: cannot insert NULL into ("PPM"."CLB_NOTIFICATION_ASSOCS"."NOTIFICATION_DEF_ID")
 
Resolution:
  1. Rollback the environment
  2. Connect to UI - Administration - Reports and Jobs
  3. Set the job Tomcat access log import/analyze with ID log_import_analyze_job to Active
  4. Retry the upgrade