Upgrade of Reporter server 4.x to version 6.x fails: "You have to be owner of reporter directory"

Document ID : KB000086272
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
##############################################################
#--------------------------------------------------
# ---> ERROR:
# -------------------------------------------------

-----> You have to be owner of reporter directory to use this procedure (admin of instance is root).
Cannot continue.

#--------------------------------------------------
# Procedure aborted.
# ----------------------------------------------
##############################################################

Patch level detected:Reporter 6.1.00
Upgrade of Reporter server 4.x to version 6.1 fails even installing it with root user and even if prior version had been installed with root.
Environment:
OS: Linux
Cause:
Cause type:
Defect
Root Cause: Incorrect usage of 'who am i' instead of 'whoami' in the installation scripts of Reporter versions 4.x /6.1.01

[root@vmstlce7 ~]# su - sysload
Dernière connexion : vendredi 17 novembre 2017 à 14:51:25 CET
[sysload@vmstlce7 ~]$ who am i
root pts/0 2017-12-28 13:11 (10.132.185.132)
[sysload@vmstlce7 ~]$ whoami
sysload
Resolution:
Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Reporter 6.2.21 - Available
Additional Information:
Workaround :
Log in Linux server as root right away instead of another user.
Then, run the upgrade procedure.