Upgrade of DSM Manager fails with error 1603 - Error Code 1

Document ID : KB000076601
Last Modified Date : 06/04/2018
Show Technical Document Details
Issue:
Upgrade of DSM Manager fails with error 1603.

In file %TEMP%\TRC_INST_ITRM_*.log following error appears :
 
start MDB installation on local machine
failed to set current working directory as <C:\Users\test_user\AppData\Local\Temp\2\ITRM\database>
    error code was set to <0>
isFreshInstall assumed <0>
run command: <C:\Program Files (x86)\CA\SC\Mdb\Windows\jre\bin\java.exe  -Djava.library.path=".\lib"   -classpath .\lib\log4j-1.2.8.jar;.\lib\ojdbc14.jar;.\lib\sqljdbc.jar;.\setup.jar;.\;.\msql\post_install.sql  ca.cms.mdb.setup.Setup  -cfg setup.properties -a  checkprereq_install/install/verifyschema/addusers/postinstall>
LaunchCmd start
LaunchCmd: Process creation succeeded
LaunchCmd: process terminated with exit code  <1>
LaunchCmd end return <TRUE>
MDB setup command error: <1>
Init: end
Schema installation failed [7]
Cause:

error code 1 indicates a problem during execution of java.exe process

The cause of problem is indicated by this line :
 
failed to set current working directory as <C:\Users\test_user\AppData\Local\Temp\2\ITRM\database>

 
Resolution:

In order to solve this problem do this on Domain ITCM :

- Open regedit and delete the registry key value TempManagerDir under

HKEY_LOCAL_MACHINE\Software\Wow6432Node\ComputerAssociates\Unicenter ITRM\Installer



See following document if error is similar but with error code 193 :
During the update of a Domain Manager to r14.0 SP2, the upgrade of the MDB fails with error 1603. What can be the reason?

And for error code 2 :
Upgrade of DSM Manager fails with error 1603