Upgrade failure to 9.3.8

Document ID : KB000096871
Last Modified Date : 06/08/2018
Show Technical Document Details
Issue:
MySQL failure on harvester upgrade to 9.3.8.
The upgrade log shows that it was failing on the "mysql_upgrade" command for NQMYSQL. 
Environment:
NFA 9.3.x on Windows 2012 R2 Harvester
Cause:
This occurred because the AppLocker component was enabled while attempting to upgrade the Harvester.
Resolution:
Disable AppLocker and antivirus software on the Harvester machine before initiating the upgrade. 
Once the condition that caused the problem is corrected, it may be possible to resume the upgrade after exiting out of a failed upgrade attempt by opening an Administrator Command Prompt to the \CA\NFA\Migrator\ directory on the Harvester and running:
runmigrator.vbs

If this does not successfully complete the Harvester upgrade, please contact CA NFA Support for assistance.
 
Additional Information:
From install docs:
https://docops.ca.com/ca-network-flow-analysis/9-3-8/en/upgrading/upgrade-ca-network-flow-analysis/verify-that-the-windows-servers-are-prepared

Verify that the following conditions are met:
.
.
.
The following third-party software is disabled until the upgrade is complete: Antivirus, server monitoring, and maintenance software. If you enable antivirus scans later, exclude the CA Network Flow Analysis installation path and its subdirectories.