CA PPM upgrade fails with "Error Applying XOG: Failure occurred while applying RemoteAppSys_Menu.xml"

Document ID : KB000072275
Last Modified Date : 28/02/2018
Show Technical Document Details
Issue:

CA PPM upgrade fails with error Error Applying XOG: Failure occurred while applying RemoteAppSys_Menu.xml

Once the upgrade fails look at the install log and you will see below error

 

9/01/16 9:34 AM (ExecTask) Updating xogseeddata for component = ppm

9/01/16 9:34 AM (ExecTask) Updating xogseeddata for component = bpm

9/01/16 9:34 AM (ExecTask) Updating xogseeddata for component = nmc

9/01/16 9:34 AM (ExecTask) Created dir: C:\CA_PPM_1330\logs\xog-seeddata\out\nmc

9/01/16 9:35 AM (ExecTask) Applying integration_agile_system.xml

9/01/16 9:35 AM (ExecTask) Applying JOB_SUPPORT_DATASCAN.xml

9/01/16 9:35 AM (ExecTask) Applying NMC_INTEGRATION_RIGHT.xml

9/01/16 9:35 AM (ExecTask) Applying NMC_INTEGRATION_STATIC_LOOKUPS.xml

9/01/16 9:35 AM (ExecTask) Applying RemoteAppSys_Menu.xml

9/01/16 9:35 AM (ExecTask) Error Applying XOG: Failure occurred while applying RemoteAppSys_Menu.xml

9/01/16 9:35 AM (ExecTask)  Check C:\CA_PPM_1330/logs/xog-seeddata/out/nmc\RemoteAppSys_Menu_out.xml for

 

Environment:
CA PPM 13.3 and above.
Cause:
The reason for this failure is because npt.systemAdmin action marked as "Hidden" but it should not be as this is a system level page.
Resolution:

1. Run the select query below 

Select * from cmn_menu_items where action_id= (select id from cmn_actions where action_code='npt.systemAdmin'); 

2. If the above query returns anything other than 0 then it was altered some how, then run the below command to fix it 

update cmn_menu_items set is_hidden=0 where action_id= (select id from cmn_actions where action_code='npt.systemAdmin'); 

Additional Information:
Note: The above command should be run after the application and database are restored to working condition from where upgrade started and after executing the command and re run the upgrade.