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Upgrade fails with "Could not contact database 'mdb' on server 'server_name' (instance'MSSQLSERVER.1433').
Document ID :
KB000050732
Last Modified Date :
14/02/2018
Show Technical Document Details
Products
CA Client Automation
CA IT Client Manager
CA Patch Manager
CA Server Automation
CA Asset Management
CA Desktop Management Suite
CA IT Asset Manager
CA Software Delivery
CA Remote Control
Releases
CA Client Automation:Release:12.5
CA IT Client Manager:Release:12.5
CA Asset Management:Release:12.5
Components
DESKTOP AND SERVER MANAGEMENT:DTSVMG
CA Asset Management:TNGAMO
CA Remote Control:TNGRCO
CA Software Delivery:TNGSDO
Description:
Problem
Upgrade from ITCM r12 SP1 to R12.5 fails with:
Environment
Microsoft Windows 2003 Server Service Pack 2 (Build 3790)
Microsoft SQL Server 2005 Service Pack 2
Solution:
Resolution
Manually install ETPKI from the ITCM DVD
The setup for CAPKI is located on the CA ITCM installation media (CD/DVD) in the WindowsProductFiles_x86\CAPKI directory.
To install the CAPKI libraries, use the following command line:
setup install caller=CADSMCAPKI
Retry upgrade of ITCM.
Cause
Incompatible version of ETPKI installed prevents the decryption of the ca_itrm users password.
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