Upgrade does not work with CAeAC-1281-1.0.2988.s390x.rpm package

Document ID : KB000110920
Last Modified Date : 13/08/2018
Show Technical Document Details
Issue:
I get an error message when I tried to use -U option with CAeAC-1281-1.0.2988.s390x.rpm package.

# rpm -U CAeAC-1281-1.0.2988.s390x.rpm

This does not work when the existing version CAeAC-1281-1.0.2265 is still installed. I can install the package after I have removed CAeAC-1281-1.0.2265, but still I need to use rpm -U option, rpm -i does not work.
Resolution:
[root@gomer02 install]# ./customize_eac_rpm -g -f easy.txt CAeAC-1281-1.0.1912.x86_64.rpm 
Extracted into <custom.txt>. 

[root@gomer02 install]# vi easy.txt 

# Specifies whether the installation warns you about using a non-default 
# encryption key. 
# Note: After upgrading, your encryption key will be set to the default. 
# Values: "yes", "no". 
# Default: "no" 
FORCE_ENCRYPT="yes" 

Save this, import the text file so it's now repackaged. 

[root@gomer02 install]# ./customize_eac_rpm -s -f easy.txt CAeAC-1281-1.0.1912.x86_64.rpm 

[root@gomer02 install]# rpm -i CAeAC-1281-1.0.1912.x86_64.rpm
Additional Information:
https://support.ca.com/cadocs/0/CA%20ControlMinder%2012%208-ENU/Bookshelf_Files/HTML/idocs/index.htm?toc.htm?1358290.html 

‑force_encrypt 
Forces the installation to accept a non-default encryption key without warning you.