Unsupported Class Version Error

Document ID : KB000088917
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Unsupported Class Version Error
Resolution:
Applicable toApplications Manager Versions:  v7.1, v8.0

Symptoms

Receive an error message 'Exception in thread "main" java.lang.UnsupportedClassVersionError' when attempting to Install or upgrade an Applications Manager instance.


Error Message Details

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/appworx/test/AxUnzip (Unsupported major.minor version 49.0)
          at java.lang.ClassLoader.defineClass0(Native Method)
          at java.lang.ClassLoader.defineClass(Unknown Source)
          at java.security.SecureClassLoader.defineClass(Unknown Source)
          at java.net.URLClassLoader.defineClass(Unknown Source)
          at java.net.URLClassLoader.access$100(Unknown Source)
          at java.net.URLClassLoader$1.run(Unknown Source)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.net.URLClassLoader.findClass(Unknown Source)
          at java.lang.ClassLoader.loadClass(Unknown Source)
          at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
          at java.lang.ClassLoader.loadClass(Unknown Source)
          at java.lang.ClassLoader.loadClassInternal(Unknown Source)


Cause

This error is displayed when there is a reference to a Java class that is unsupported for the JDK or JRE that is installed on your system.  This is common as newer versions of Applications Manager make use of new Java technology.  You may have older versions of Java installed because Oracle installs Java by default and those older versions of Java may be listed first in your path when Oracle was installed, so it is attempting to use that Java version.


Solution

If you encounter this error, you will need to install a newer version of Java on this machine.  If you already have a newer version of Java installed, you need to ensure that the newer Java version is listed first in the $PATH/%PATH% environment variable on your system so that it is the version that is found during the install.  Applications Manager v8 supports Java 1.6 and above and many of the Rapid Automation Agents take advantage of the newer Java technology so Java 1.6 is recommended.

You can verify the version of Java that is installed by running the following command:

     java -version

You can see where java is installed by using the appropriate command:

     which java (Unix)
     where java (Windows)

If you do not see the Java version that you would like to use, please contact your System Administrator.