UniJob crashes after installation on Linux 64-bit

Document ID : KB000085605
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Affects Release version(s): 1

Error Message :
No errors in <unijob>/data/log/unijob.log

No missing libraries when executing "ldd -v uniio"

When activating strace 
(strace -p <pid_uniio|pid_unicdj|pid_unilan|pid_unical> -o unijob_strace.txt)
###
[pid 48698] stat64("/lib/tls/i686/sse2", <unfinished ...>
[pid 48702] <... mmap2 resumed> ) = 0xfffffffff7793000
[pid 48698] <... stat64 resumed> 0xf772cc0c) = -1 ENOENT (No such file or directory)
[pid 48702] close(4 <unfinished ...>
[pid 48698] open("/lib/tls/i686/libgcc_s.so.1", O_RDONLY <unfinished ...>
[pid 48702] <... close resumed> ) = 0
[pid 48698] <... open resumed> ) = -1 ENOENT (No such file or directory)
[pid 48702] open("/lib/tls/i686/sse2/libgcc_s.so.1", O_RDONLY <unfinished ...>
[pid 48698] stat64("/lib/tls/i686", <unfinished ...>
[pid 48702] <... open resumed> ) = -1 ENOENT (No such file or directory)
[pid 48698] <... stat64 resumed> 0xf772cc0c) = -1 ENOENT (No such file or directory)
[pid 48702] stat64("/lib/tls/i686/sse2", <unfinished ...>
[pid 48698] open("/lib/tls/sse2/libgcc_s.so.1", O_RDONLY <unfinished ...>
[pid 48702] <... stat64 resumed> 0xf7766c2c) = -1 ENOENT (No such file or directory)
[pid 48698] <... open resumed> ) = -1 ENOENT (No such file or directory)
[pid 48702] open("/lib/tls/i686/libgcc_s.so.1", O_RDONLY <unfinished ...> 
###
This shows that libgcc (32-bit) is missing

Patch level detected:Unijob 1.4.0
Product Version: Unijob 1.4.5

Description :1. UniJob is freshly installed
2. UniJobs starts normally
3. Interaction with the UniJob's IO crashes all UniJob processes

# Examples of interactions are:
- creating an object from Univiewer,
- creating a job with uniadd,
- telnet
Environment:
OS: Linux
OS Version: RHEL6.x (64bits)
Cause:
Cause type:
Configuration
Root Cause: The 32-64 bit compatibility library libgcc is missing.
Resolution:
Install the missing compatibility 32-64 bit libraries:
yum install glibc.i686
yum install libgcc.i686

Fix Status: No Fix
 
Additional Information:
Workaround :
N/A