Unified Self-Service (USS) Windows services don't appear and the installer fails when validating the installation

Document ID : KB000111944
Last Modified Date : 27/08/2018
Show Technical Document Details
Issue:
USS is not getting installed. USS Windows services don't appear and the installer fails when validating the installation.

In install.log:

DEBUG [DeployThread: Instalación de Unified Self-Service] [InstallOSOP] Starting Unified Self Service install/upgrade.
INFO [DeployThread: Instalación de Unified Self-Service] [InstallOSOP] Unified Self Service osop_installer.properties "<local drive>:\Users\<username>\AppData\Local\Temp\\osop_installer.properties"
DEBUG [DeployThread: Instalación de Unified Self-Service] [InstallOSOP] Unified Self Service Install/Upgrade Command: "<local drive>:\\products\SelfService\OSOP_Windows_Installer\Disk1\InstData\VM\install.exe" -i silent -f "<local drive>:\Users\admin_ca\AppData\Local\Temp\\osop_installer.properties"
INFO [DeployThread: Instalación de Unified Self-Service] [ActiveProcessHolder] Windows Process ID (PID): <PID>
INFO [DeployThread: Instalación de Unified Self-Service] [ActiveProcessHolder] Start Monitor. Process ID (PID): <PID>
INFO [DeployThread: Instalación de Unified Self-Service] [ActiveProcessHolder] Exit Monitor. Process ID (PID): <PID>
DEBUG [DeployThread: Instalación de Unified Self-Service] [CommonProcessUtilities] Command terminated with exit code: 1
DEBUG [DeployThread: Instalación de Unified Self-Service] [InstallOSOP] Unified Self Service Exit Code: 1

DEBUG [DeployThread: Instalación de Unified Self-Service] [InstallOSOP] Updating <Change Unified Self-Service Installation.lax> started...

 
Environment:
Service Management 14.1 and later
Unified Self-Service (USS) 14.1 and later
Cause:
Symantec Antivirus is blocking and stopping the installer to complete the installation. The install.log should show:

[CommonProcessUtilities] Command executed sucessfully
[InstallOSOP] Unified Self Service Exit Code: 0

instead of:

[CommonProcessUtilities] Command terminated with exit code: 1
[InstallOSOP] Unified Self Service Exit Code: 1
 
Resolution:
1. Ask the administrator to stop Symantec AntiVirus processes in the server where you will install USS.
2. Close USS installer
3. Run USS installer and proceed with the installation once Symantec AntiVirus processes are not running.