Unified Dashboards show no data, data_engine log reports MySQL_BulkInsert::Commit: Table 'ca_uim.t_qos_snapshot' doesn't exist

Document ID : KB000008785
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

A Database issue on the primary hub caused the database to run out of space. After resolving this there were no data in Unified dashboards or metrics tabs in USM.

When checking the data_engine log there are multiple errors like

Nov 17 10:40:11:850 [139957146482432] de: data_engine [LSV] [LSV] - MySQL_BulkInsert::Commit - Error: [LSV] thread_id: 50255, error: MySQL_BulkInsert::Commit: Table 'ca_uim.t_qos_snapshot' doesn't exist (errno:1146)

Cause:

The db space issue has caused a db corruption.

Resolution:
  • recreate the data_engine tables by running
    • ......\Nimsoft\probes\slm\data_engine\scripts¬†
      <dbms>_dataengine_create