Unexpected behavior when scheduling reports on CABI 6.3

Document ID : KB000008241
Last Modified Date : 14/02/2018
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Issue:

- You create a report schedule. When saving it, the following error is displayed, but no details provided:

"Failed to save the scheduled job.
The full response from the server is:"

Error on Save Schedule.PNG

 

- Additionally, the scheduled jobs list remains empty after creating the schedule:

Empty Schedule List.png

 

- But the schedule works fine. You can see in the reports list that it was scheduled:

Report List with Schedule Present Symbol.PNG

Environment:
Spectrum 10.2.xCABI 6.3
Cause:

This problem is caused due some inconsistency in one or more files located at "$CATALINA_HOME/work/Catalina/localhost/jasperserver-pro/work" folder, in CABI 6.3 server.

Resolution:

1- On CABI 6.3 server, rename the "$CATALINA_HOME/work/Catalina/localhost/jasperserver-pro/work" folder.

2- Restart the Tomcat service. A new "work" folder will be created.