Unable to use UIM CA Business Intelligence Dashboards (error 403)

Document ID : KB000072940
Last Modified Date : 07/06/2018
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Issue:
We have a new installation of the CABI (bundled) and we can no longer get in to the cabi reports from the UMP.
The Web Browser Developer Tools shows a "403" when trying to load the CABI URL.  

 
Environment:
UIM 8.5.1
RHEL 7
Oracle 12c
Cause:
The superuser password in jaspersoft may have been changed after the initial deployment of cabi and/or the keystore files are corrupt or out of sync between the cabi probe and the cabi wasp.
Resolution:
1- On the 'cabi' robot 
    Copy the uim.jks keystore file from:
./probes/service/cabi/keystore/uim.jks
to
./probes/service/wasp/webapps/cabijs/WEB-INF/config/uim.jks

2- Restart the cabi and wasp probes on the cabi robot.

If it still fails and this is a new installation of bundled cabi, please perform the following steps below.

1- Using the IM Console, Deactivate wasp and cabi probes on cabi robot 
2- Using the IM Console, Delete wasp and cabi probes on cabi robot 
3- On the file system of the cabi robot, delete these folders: 
/opt/nimsoft/probes/service/cabi 
/opt/nimsoft/probes/service/wasp 
Restart cabi robot (Nimsoft service) 

4- Run the Oracle script to drop cabi tables in Oracle as the UIM database user(schema). Please see file attachment.
File name:dropCABI_tables_Oracle.sql 

5- Deploy the cabi probe to the cabi robot. 

6- Monitor cabi robot - cabi log (takes a few minutes for the probe to show up). 
A successful deployment will show something like the following in the log file: 
Mar 07 12:38:52:564 [main, cabi] changing probe state 
from 'INITIALIZING' to 'INSTALLING_CABI' 
Mar 07 12:38:52:565 [main, cabi] extracting cabi installer ... 

7- Monitor the cabi log: 
Mar 07 12:46:32:929 [main, cabi] 
****************[ Starting ]**************** 
Mar 07 12:46:32:929 [main, cabi] 3.2.0 
.... 
Mar 07 12:50:19:378 [main, cabi] changing probe state from 
'INSTALLING_CABI' to 'STARTING_WASP' 
Mar 07 12:50:19:378 [main, cabi] activating wasp... 
Mar 07 12:50:19:385 [main, cabi] waiting for wasp to start... 


10- Login to cabi directly. For example: 
http://hostname/cabijs/ 
superuser / superuser 
 
 
11- Deploy uim_core_dashboards and other uim_###_dashboards to the cabi robot. 


12- Deploy ump_cabi 3.20 to UMP robot. 
Monitor UMP wasp for errors  Wasp will take a few minutes to restart. 


 
Additional Information:
Other errors:
Build Failed Error:
Mar 08 16:33:31:941 [main, cabi] running cabi installer... 
Mar 08 16:34:56:465 [Thread-2, cabi] 
Mar 08 16:34:56:465 [Thread-2, cabi] BUILD FAILED 
Mar 08 16:34:56:465 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:187: The following error occurred while executing this line: 
Mar 08 16:34:56:465 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:245: The following error occurred while executing this line: 
Mar 08 16:34:56:465 [Thread-2, cabi] /opt/nimsoft/c/ca_install/build.xml:838: Installation of CA Business Intelligence failed 
Mar 08 16:34:56:465 [Thread-2, cabi] 
Mar 08 16:34:56:465 [Thread-2, cabi] Total time: 1 minute 24 seconds 
Mar 08 16:34:56:482 [main, cabi] cabi installer completed with exit code=1 [time taken=1 minute(s) 24 second(s) (84540 ms)] 

1- Deactivate the cabi probe. 
2- Delete the cabi probe. 
3- Start wasp if not started or restart it on the cabi robot. 
4- Once wasp is started, deploy the cabi probe. 
5- Deploy uim_core_dashboards and other uim_###_dashboards to the cabi robot. 
6-  Deploy ump_cabi 3.20 to UMP robot. 
Monitor UMP wasp for errors  Wasp will take a few minutes to restart.


Error concerning data_engine while deploying cabi
Mar 09 08:27:14:733 ERROR [main, com.nimsoft.nimbus.probe.service.wasp.Probe] main() Fatal error! 
Mar 09 08:27:14:735 ERROR [main, com.nimsoft.nimbus.probe.service.wasp.Probe] main() (90) Configuration error, No connection string found. Make sure that data_engine is running or that there is a connection string saved in your .cfg file. 
Mar 09 08:27:14:736 ERROR [main, com.nimsoft.nimbus.probe.service.wasp.Probe] (90) Configuration error, No connection string found. Make sure that data_engine is running or that there is a connection string saved in your .cfg file. 

 
1- Deactivate the cabi probe. 
2- Delete the cabi probe 
3- Navigate to the "data_engine" probe on the primary hub. 
4- Right Click > "Edit" > "Copy to Clipboard" 
5- Paste into Notepad. 
6- Look for the data_engine address. 
For example: 
/hostname-E11028_domain/hostname-E11028_hub/hostname-E11028/data_engine 

7- Raw Configure for the 'wasp' probe on the cabi robot. 
8- Look for a "data_engine" key under <setup>. 
If not found, create it. 
Enter the value for the key as the data_engine address. 
Save > "OK" 
9- Ensure that the 'wasp' probe restarts. 
10- Deploy the cabi probe. 
11- Deploy uim_core_dashboards and other uim_###_dashboards to the cabi robot. 
12- Deploy ump_cabi 3.20 to UMP robot. 
Monitor UMP wasp for errors  Wasp will take a few minutes to restart.


 
File Attachments:
dropCABI_tables_Oracle.sql