Unable to upgrade the Data Aggregator

Document ID : KB000007789
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When attempting to upgrade the Data Aggregator it fails due to being unable to connect to the Data Repository

Environment:
Performance Management 2.7+
Cause:

It is possible that the /etc/DA.cfg has the incorrect entry for the da.karaf.home which leads to the installer being unable to find the dbconnection.cfg file which contains how to access the Data Repository.

Resolution:

Fix the DA.cfg file to reference the proper apache karaf directory and reattempt the installation

Additional Information:

Errors in the installation log (in the home directory of the install user):

java.io.FileNotFoundException: /opt/CA/IMDataAggregator/apache-karaf-2.3.0/etc/dbconnection.cfg (No such file or directory)

 

In this case, the path should be:

/opt/CA/IMDataAggregator/apache-karaf-2.4.3/etc