Unable to update any hardware assets. Time out error

Document ID : KB000072872
Last Modified Date : 09/03/2018
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Issue:
It took about 20 minutes after clicking SAVE, then finally receive this error: System.Net.WebException: The operation has timed out at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)… at CA.Common.Web.Services.DataBroker.SaveCachedValuesToDatabase
Environment:
CA Asset Portfolio Management 14.1
Cause:
The application was unable to reach or perform the database record save in SQL Server. 
SQL Server is either too busy to perform the action or the tempDB was reaching capacity. 
Resolution:
Resolve by
1.  Restart the SQL server services (this clears the SQL Server tempDB)
2.  Perform an IISRESET on both the APM web and application servers.