Unable to uninstall PIM

Document ID : KB000045720
Last Modified Date : 14/02/2018
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Issue: 

 

Unable to uninstall PIM.

 

When uninstallation is attempts on ControlPanel that show error message

"Error 1314.The specified path1033.MST is unavaliable".

 

Environment:  

 

PIM 12.9 on Windows 2012R2

 

Cause: 

 

This could be caused due to interrupted earlier uninstallation and left some components.

 

Resolution/Workaround:

 

1. In registry go to:

 

HKEY_CLASSES_ROOT\Installer\Products\CDAFB228040EC5F40AA08B5E852A6D61

 

Change the "Transforms" registry value to @1033.mst (the original value was "1033.mst" so only add @ at the beginning).

 

 

 

2. Go to Add/Remove Programs and uninstall "CA Access Control".

 

It should be removed with no error. Reboot the machine (in case of successful uninstall).

 

If you still get any error please run uninstall with log file via command line:

 

Msiexec.exe /x {822BFADC-E040-4F5C-A00A-B8E558A2D616} /l*v <log_file_name>

 

And provide me the uninstall log file.

 

 

 

3. In case of successful uninstall (step 2) please verify that all PIM files have been removed from the Install folder

 

(The default install folder:

 

<Local Drive>:\Program Files\CA\AccessControl should not exist anymore).

 

Please also verify that the drivers binaries have been removed from Disk: Go to <LocalDrive>:\Windows\System32\Drivers and verify that cainstrm.sys,

 

drveng.sys and seosdrv.sys don't exist there. If they exist please remove them.

 

 

 

4. Please verify that AC entry in registry has been removed:

 

HKLM\SOFTWARE\ComputerAssociates\AccessControl should not exist.

 

If it still exists please delete it.

 

 

 

5. Please open the services view (services.msc) and check that there are no PIM services (CA Access Control Agent/Engine/Watchdog/Task Delegation/Report Agent/Policy Model). If one of the services still exists

 

please remove it by running the following through command line:

 

Sc delete <service name>

 

And then verify that the service has been removed from services view.

 

 

 

6. Please verify that all drivers services have been removed. In the registry the following entries should not exist: HKEY_LOCAL_MACHINE\SYSTEM

 

\CurrentControlSet\Services\cainstrm

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\drveng

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\seosdrv

 

If some driver service still exists in registry please run the following from command line:

 

Sc delete <driver name>

 

Where driver name can be: cainstrm, drveng or seosdrv.

 

After deleting the service verify in registry that it has really been removed.

 

 

 

7. Reboot the machine and after reboot try to run PIM installation again.