Unable to sync with SaaS portal from hybrid gateway (on prem)

Document ID : KB000074006
Last Modified Date : 16/03/2018
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Issue:
Audit log shows all sync tasks failing with messages similar to this one: Problem routing to https://<PORTAL_HOSTNAME>:443/sync/2.0/apis?identifier=6477eba3-3709-40df-ba3b-33aea780bc0c&nodeId=3f3f8187-e8d3-454a-abda-26daed7d9668. Error msg: Unable to obtain HTTP response from https://<PORTAL_HOSTNAME>:443/sync/2.0/apis?identifier=6477eba3-3709-40df-ba3b-33aea780bc0c&nodeId=3f3f8187-e8d3-454a-abda-26daed7d9668: Connect to <PORTAL_HOSTNAME>:443 timed out

Testing with CURL was able to connect from the gateway to the specified url, though received a 500 Server Error (not unexpected).
Environment:
SaaS Portal with On-Prem gateway(Hybrid deployment model)
Cause:
On-Prem gateway requires use of a proxy to connect to machines outside of the customer's local environment
Resolution:
HTTP Route assertions need to be updated to use proxy information required for the environment. A list of the assertions that need to be modified for the Portal integration is attached(DE342761_Routing_Assertions_List.xlsx)
File Attachments:
DE342761_Routing_Assertions_List.xlsx